Service Disruption - "Test Linguistic Resources"

Incident Report for TC Test Page

Resolved

The issue affecting "Test Linguistic Resources" has now been resolved
Posted Aug 16, 2026 - 21:15 UTC

Investigating

We are currently investigating an issue affecting "Test Linguistic Resources"
Posted Aug 16, 2026 - 21:14 UTC
This incident affected: Trados Cloud (NASA) (Test Linguistic Resources (NASA)).