Service Disruption - "Test Reports"

Incident Report for TC Test Page

Resolved

The issue affecting "Test Reports" has now been resolved
Posted Jun 24, 2026 - 04:32 UTC

Investigating

We are currently investigating an issue affecting "Test Reports"
Posted Jun 24, 2026 - 04:31 UTC
This incident affected: Trados Cloud (EMEA) (Test Reports (EMEA)).