Service Disruption - "Test Online Editor"

Incident Report for TC Test Page

Resolved

The issue affecting "Test Online Editor" has now been resolved
Posted Aug 26, 2026 - 18:13 UTC

Investigating

We are currently investigating an issue affecting "Test Online Editor"
Posted Aug 26, 2026 - 18:13 UTC
This incident affected: Trados Cloud (EMEA) (Test Online Editor (EMEA)).